CyCraft Technology, Xensor, Next-Generation MDR Endpoint Security System, Logo

Next-Gen MDR Endpoint Security

XENSOR

Combining machine learning with unique forensic telemetry technology, Xensor provides highly efficient automated threat triage and remote endpoint access for incident investigation and threat hunting.

An evolution above current security products, Xensor integrates multi-dimensional threat intelligence, including UEBA, program memory forensics, endpoint computer forensics, and network traffic analysis, without additional virus signatures or feature rules, to expediently respond and reduce security costs.

FAST / ACCURATE / SIMPLE / THOROUGH

FAST / ACCURATE
/ SIMPLE / THOROUGH

FITS ALL ENVIRONMENTS

Easily deployed on-prem or in the cloud, our scanners can be agent-based or installation-free.

STRENGTHEN FORENSICS

Proactive threat hunting supports Windows, Linux and MACOS to identify latent threats and hacker behavior trajectories, to give you the ability to fully carry out forensic investigations.

ACHIEVE COMPETITIVE ROI

Improve your security team’s operational efficiency. Rapidly respond to malicious threats, minimize losses, and strengthen your enterprise’s security operations.

CyCraft Technology, Xensor, Endpoint Security Platform, Xensor Dashboard, Endpoint View

Key Features

  • Intelligent APT situational awareness
  • Efficient, lightweight, multi-platform
  • Continuous monitoring & rapid response
  • Malware & memory forensics
  • Integration of MITRE ATT&CK International Security Framework to identify attack chains

Supported Operating Systems:

SUPPORTED

OPERATING

SYSTEMS

Windows (x64)

  • Windows 11
  • Windows 10
  • Windows 8.1
  • Windows 8
  • Windows 7 SP1
  • Windows Server 2022
  • Windows Server 2019
  • Windows Server 2016
  • Windows Server 2012 R2
  • Windows Server 2012
  • Windows Server 2008 R2 SP1

Legacy OS Support available on request.

Linux (x64)

  • Ubuntu 9.10 ~ 22.04
  • CentOS 6.0 ~ 8.4
  • Debian 7.0 ~ 11.0
  • Red Hat Enterprise 6.0 ~ 8.3
  • Alma Linux 8.5
  • OpenSUSE 15.1 ~ 15.3
  • Oracle Linux 7.9 and 8.5
  • Rocky Linux 7.9 and 8.5

MacOS (x64)

Your CyCraft representative is standing by to help you with an incident or answer any question regarding our incident response, compromise assessment, or managed detection and response products and services.

Get in touch